Difference: TWikiSystemRequirements (11 vs. 12)

Revision 122001-09-01 - MikeMannix

Line: 1 to 1
 
Changed:
<
<

TWiki Software Environment

>
>

TWiki Operating Environment

 
Changed:
<
<

System Requirements

>
>
Low requirements on client-side and server-side environment, to keep TWiki deployment as broad as possible is a key element of the TWikiMission. Strict W3C and ECMA standards compliance is also a mandate. These requirements are amended from time to time as technology progresses.
 
Changed:
<
<
TWiki is written in Perl 5 and also uses some shell commands. It also requires that GNU RCS (Revision Control System) is installed on the same system. The current implementation runs best on a Linux machine, but it can also run with Microsoft Windows.
>
>

Server-Side Requirements

 
Changed:
<
<
Required Environment by Platform
Packages: Linux/Unix: Windows:
Perl 5.x 5.x
Non-standard Perl modules ??? MIME::Base64, Digest::SHA1 (for password generation)
Optional Perl modules Net::SMTP (or sendmail) Net::SMTP
RCS 5.7 5.7 (including diff
Other external programs ls, fgrep, egrep ls, fgrep, egrep
Web server Apache Apache, IIS
>
>
TWiki is written in Perl 5 and uses a number of shell commands. It requires that GNU RCS (Revision Control System) be installed on the same system. Current development is on Linux. the recommended platform, but it can also work with Microsoft Windows and other OS.

Required Server Environment by Platform
Resource Unix Windows
Perl 5.005_03 or higher
Non standard Perl modules Net::SMTP (or sendmail) Net::SMTP
RCS 5.7 or higher
Other external programs ls, fgrep, egrep
Web server Apache and others (support for cgi, authentication, extended path) *
 
OS versions Linux, Unix... every last Win?!
Added:
>
>
Required disk space    

ISP INSTALLATION REQUIREMENTS: SSI, RCS local or sysadmin, same for perl modules for plugins, cron, basic authentication,...

Client-Side Requirements

The basic TWiki engine and templates have a low requirement on the browser:

Recommend PC Requirement
Component Min/Rec

Browser Requirements
Resource Details
HTML 3.2 browser  
JavaScript 1.? Optional: JS degrades gracefully
Cookies Not used
CSS1/2 ????

  • TWiki generates XHTML 1.0 code as long as it is compatible with HTML 3.2.

WHAT ABOUT WEB STANDARDS PROJECT - CSS CONTROL

Known Issues

  • Some TWikiSkins may require more, like cookies and JavaScript
  • At present, contributed Plugins are not checked against compatibility standards, and may require anything imaginable: browser-specific functions, Java, cookies, CSS, etc.
 

TWiki Directory Structure

Line: 370 to 397
 
TWiki/RandyKramer.txt,v xxxx
TWiki/RegularExpression.txt xxxx
TWiki/RegularExpression.txt,v xxxx
Changed:
<
<
TWiki/RenameTopic.txt xxxx
TWiki/RenameTopic.txt,v xxxx
>
>
TWiki/ManagingTopics.txt xxxx
TWiki/ManagingTopics.txt,v xxxx
 
TWiki/SearchDoesNotWork.txt xxxx
TWiki/SearchDoesNotWork.txt,v xxxx
TWiki/SimultaneousEdits.txt xxxx
Line: 388 to 415
 
TWiki/TextFormattingRules.txt,v xxxx
TWiki/TWikiAccessControl.txt xxxx
TWiki/TWikiAccessControl.txt,v xxxx
Changed:
<
<
TWiki/TWikiAdministration.txt xxxx
TWiki/TWikiAdministration.txt,v xxxx
>
>
TWiki/ManagingWebs.txt xxxx
TWiki/ManagingWebs.txt,v xxxx
 
TWiki/TWikiUserAuthentication.txt xxxx
TWiki/TWikiUserAuthentication.txt,v xxxx
TWiki/TWikiCategoryTable.txt xxxx
Line: 412 to 439
 
TWiki/TWikiImplementationNotes.txt,v xxxx
TWiki/TWikiInstallationGuide.txt xxxx
TWiki/TWikiInstallationGuide.txt,v xxxx
Changed:
<
<
TWiki/TWikiNotificationOfChanges.txt xxxx
TWiki/TWikiNotificationOfChanges.txt,v xxxx
>
>
TWiki/WebNotification.txt xxxx
TWiki/WebNotification.txt,v xxxx
 
TWiki/TWikiPlannedFeatures.txt xxxx
TWiki/TWikiPlannedFeatures.txt,v xxxx
TWiki/TWikiPlugins.txt xxxx
 
This site is powered by the TWiki collaboration platform Powered by PerlCopyright © 1999-2019 by the contributing authors. All material on this collaboration platform is the property of the contributing authors.
Ideas, requests, problems regarding TWiki? Send feedback
Note: Please contribute updates to this topic on TWiki.org at TWiki:TWiki.TWikiSystemRequirements.